AS配置使用Kotlin

AS配置使用Kotlin

需要配置IDE Kotlin plugin、Kotlin Gradle plugin、Kotlin library。

  • IDE kotlin plugin
    AS 3.0 已经集成了,不需要单独安装。3.0以前的版本需要在setting-plugin中搜索kotlin,直接安装。

  • Kotlin Gradle plugin
    这个需要在project level build.gradel 中添加

    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    ext.kotlin_version = '1.1.2'
    dependencies {
    classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"
    //其他配置
    }
    allprojects {
    repositories {
    jcenter()
    mavenCentral()//kotlin library 需要这个central
    }
    }
  • Kotlin library
    在app level build.gradle中添加

    1
    2
    3
    4
    5
    dependencies {
    apply plugin: 'kotlin-android'
    compile "org.jetbrains.kotlin:kotlin-stdlib:$kotlin_version"
    //其他引用
    }

Java 代码转换为Kotlin

快捷键:Ctrl+Alt+Shift+K